PROBLEMA

Su un client Notyo si verifica il seguente errore all’avvio e non è possibile procedere:

Sub.Aggiorna_DLL_NET_Copia.Classe=IBIT_RegASM. Errore = 0-
- Variabile_GPS = Elimina_DLL -> C:\Program Files (x86)\Info-Bit\Notyo\bin\IB.AlertManager.Core.dll

Il file indicato dopo “Variabile_GPS = Elimina_DLL ->” può essere diverso a seconda dei casi.

CAUSA

Ad ogni avvio di Notyo viene effettuato un confronto di versione tra il server e il client e in caso sia disponibile un aggiornamento viene scaricato automaticamente in locale.

Questo errore si verifica se dei moduli di Notyo rimangono aperti sul PC, di conseguenza alcuni file sono bloccati e l’aggiornamento non va a buon fine.

SOLUZIONE

Per risolvere il problema bisogna chiudere i moduli interessati e riprovare ad avviare Notyo in modo che aggiorni correttamente tutti i file locali.

Alert Manager

L’errore più frequente solitamente indica che è rimasto aperto il modulo Alert Manager, ovvero il modulo che si occupa di visualizzare a schermo gli alert pianificati per l’utente, in tal caso è sufficiente chiuderlo cliccando con il tasto destro sull’icona arancione nella barra di stato e selezionando “Esci” (v. immagine):

Icona Alert Manager nella barra di stato con visualizzato il menu di chiusura.

Altri moduli

In tutti gli altri casi, se non riuscite ad individuare e chiudere manualmente il modulo, la soluzione più semplice è disconnettere e riconnettere l’utente (logout/login) oppure riavviare direttamente il PC.

Una volta fatto, riprovate ad avviare Notyo e dovrebbe aprirsi correttamente.