PROBLEMA
Quando si cerca di avviare il client Notyo non viene visualizzata la finestra di accesso e non viene visualizzato alcun errore a schermo.
Nel Registro eventi di Windows viene registrato il seguente errore .NET Runtime:
Applicazione: IB.Notyo.UI.Win.Menu.exe Versione framework: v4.0.30319 Descrizione: il processo è stato terminato a causa di un'eccezione non gestita. Informazioni sull'eccezione: System.BadImageFormatException in IB.Notyo.Servizi.ServiziConfigUtente.LoadConfig() in IB.Notyo.Servizi.ServiziConfigUtente..cctor() Informazioni sull'eccezione: System.TypeInitializationException in IB.Notyo.Servizi.ServiziConfigUtente.get_Config() in IB.Notyo.UI.Win.Menu.mdlStart.Main()
CAUSA
In uno degli ultimi aggiornamenti di Notyo si è resa necessaria la migrazione di un file di configurazione in un nuovo formato. Di norma questa migrazione è trasparente e si verifica senza problemi, può capitare tuttavia che non venga completata correttamente e in questo caso si verifica il problema in oggetto.
SOLUZIONE
Per risolvere il problema basta eliminare il file User.config nella cartella C:\Users\<nomeutente>\AppData\Roaming\Info-Bit.
PROCEDURA MANUALE
- Aprite Esplora file (Computer/Questo PC);
- Copiate il seguente percorso nella barra degli indirizzi e cliccate INVIO sulla tastiera:
%appdata%\Info-Bit
- Eliminate il file User.config (ci sarà anche un UserConfig.json, lasciatelo dov’è)
- Avviate nuovamente Notyo, ora la finestra di accesso dovrebbe aprirsi correttamente
PROMPT DEI COMANDI
Da prompt dei comandi (utente corrente) eseguire il seguente comando:
del /Q "%appdata%\Info-Bit\User.config"
POWERSHELL
Da powershell (utente corrente) eseguire il seguente comando:
Remove-Item -Force "${env:appdata}\Info-Bit\User.config"